[asterisk-users] MixMonitor Files Always Empty

Mark Farmer mark.farmer at gagenetworks.com
Wed Apr 22 11:35:25 CDT 2015

Hi, sorry to bump this one but I still have this problem.

The file is always created but is always zero size. This is the dial plan that records the call:

exten = _0[1-8]X.,1,Set(CALLFILENAME=/var/spool/asterisk/callrecordings/its/${STRFTIME(${EPOCH},,%Y/%m/%d)}/Outbound-${UNIQUEID})
exten = _0[1-8]X.,2,MixMonitor(${CALLFILENAME}.gsm,b)

The dial plan then calls a macro that makes the call.
I’ve tried adding a StopMixMonitor after calling the macro but that did not help and I have tried putting an Answer() at the start of the dial plan.

I am currently using the Monitor application instead which is working OK but I’d much rather stick with MixMonitor.

Asterisk version is now 11.17.1


From: Mark Farmer
Reply-To: "asterisk-users at lists.digium.com<mailto:asterisk-users at lists.digium.com>"
Date: Friday, 10 April 2015 16:34
To: "asterisk-users at lists.digium.com<mailto:asterisk-users at lists.digium.com>"
Subject: [asterisk-users] MixMonitor Files Always Empty

Hi all, I’m having an issue with MixMonitor in Asterisk 11.17.0. The gsm files are always created but no audio is being written to them regardless of whether or not I use the b option.
I’ve tried switching to the Monitor application and that is working just fine.

Has anyone else seen this? Am I missing something somewhere? I’ve never seen this before.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20150422/7635ce89/attachment.html>

More information about the asterisk-users mailing list