[asterisk-users] Realtime integration: Unregistered clients showing as registered?

Olli Heiskanen ohjelmistoarkkitehti at gmail.com
Wed May 14 06:12:05 CDT 2014


After a small break from working on this, I got the idea of tcpdumping the
correct ports. What I see is REGISTER messages from Kamailio port to
Asterisk, which are replied with 401 Unauthorized. Why is this happening?
In my sippeers table the secret field has no value (tried both NULL and
empty string) and the added field sippasswd has the correct password for
the user.

The above might be the cause of my problem, would anyone be able to advice
me to get to correct behaviour? Now Kamailio sees the clients as
registered, which would be wrong if Asterisk doesn't.


2014-04-24 11:27 GMT+03:00 Olli Heiskanen <ohjelmistoarkkitehti at gmail.com>:

> Hello all,
> I've been testing a Kamailio Asterisk Realtime integration, and found a
> strange situation.
> My problem is that when using the integration, everything seems ok but
> Asterisk does not see the clients as registered. Kamailio and the clients
> report registered clients. Also calls fail.
> In Asterisk cli sip show peers shows nothing but for example realtime load
> sipusers name 660 shows the user data. Field regseconds has a value and
> fullcontact has value 'sip:660 at' (kamailio ip:port as they
> are on the same machine).
> I have a very simple dialplan:
> [general]
> [default]
> exten => _XXX,1,NoOp(general : Dialed ${EXTEN})
>  same => n,Dial(SIP/${EXTEN},3600,rt)
>  same => n,Hangup
> Here's more on my problem and background to it, guys on the Kamailio list
> helped out but looks like I need to check my Asterisk configuration.
> https://www.mail-archive.com/sr-users@lists.sip-router.org/msg18555.html
> My goal is to have all clients in the asterisk database, asterisk (one at
> this point, several later) handling the calls and Kamailio as proxy. In
> Kamailio I have the WITH_MULTIDOMAIN directive on but I'm using only one
> domain 'testers.com'.
> I have Asterisk 11.8.1 and Kamailio 4.2.0-dev4 on CentOS 6.5, all are on
> the same rental virtual server. Clients are in my home network behind nat.
> In MySQL I have database asterisk with table sippeers, where I have
> clients added like this:
> INSERT INTO sippeers
> (name,defaultuser,host,sippasswd,fromuser,fromdomain,callbackextension,type)
> VALUES ('660', '660', 'dynamic', 'password', '660', 'testers.com
> ','660','friend');
> In this message there are some outputs and a sip trace of a register:
> https://www.mail-archive.com/sr-users@lists.sip-router.org/msg18558.html
> What I don't know is how to configure sip.conf, so far I've just been
> making guesses based on online examples and documentation.
> My current sip.conf looks like this:
> [general]
> bindport = 5070
> bindaddr =
> tcpbindaddr =
> tcpenable = no
> limitonpeers = yes
> ;rtcachefriends = yes
> tos_sip=cs3
> tos_audio=ef
> realm = testers.com
> I've tried defining realm and domain values, but I lack proper
> understanding of those. Can you guys help me out? Are there any other
> configurations I need to check?
> Respectfully,
> Olli
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20140514/ab14a20c/attachment.html>

More information about the asterisk-users mailing list