[asterisk-users] Fax buffer overflow detected

Larry Moore lmoore at omninet.net.au
Thu Feb 6 18:35:19 CST 2014

On 7/02/2014 3:38 AM, Tech Support wrote:
> All;
> I’m running Asterisk 1.8.15-cert3 with the newest version of spandsp.
> I’ve even tried unloading that and using Digium’s FFA module but I
> receive the same error on an outbound transmission:
> [2014-02-06 14:35:14] ERROR[19066]: udptl.c:294 encode_open_type: UDPTL
> (SIP/XXXXXXXXXXX_outbound-00000000): Buffer overflow detected (59 + 127
>  > 175)
> I only get this with one specific upstream provider. Has anyone seen
> this before? Any help at all would be greatly appreciated.

Not sure if this relates to T38FaxMaxDatagram, here is an extract from a 
sample sip.conf file.

; In some cases, T.38 endpoints will provide a T38FaxMaxDatagram value 
(during T.38 setup) that
; is based on an incorrect interpretation of the T.38 recommendation, 
and results in failures
; because Asterisk does not believe it can send T.38 packets of a 
reasonable size to that
; endpoint (Cisco media gateways are one example of this situation). In 
these cases, during a
; T.38 call you will see warning messages on the console/in the logs 
from the Asterisk UDPTL
; stack complaining about lack of buffer space to send T.38 FAX packets. 
If this occurs, you
; can set an override (globally, or on a per-device basis) to make 
Asterisk ignore the
; T38FaxMaxDatagram value specified by the other endpoint, and use a 
configured value instead.
; This can be done by appending 'maxdatagram=<value>' to the t38pt_udptl 
configuration option,
; like this:
; t38pt_udptl = yes,fec,maxdatagram=400 ; Enables T.38 with FEC error 
correction and overrides
;                                       ; the other endpoint's provided 
value to assume we can
;                                       ; send 400 byte T.38 FAX packets 
to it.


More information about the asterisk-users mailing list