[asterisk-users] PJSIP configuration question

Dan Cropp dan at amtelco.com
Wed Dec 10 09:25:59 CST 2014

I'm working with a SIP provider to try and transition our sip connection with them to PJSIP.  I thought I had transitioned the settings correctly, but whenever I attempt an Originate it never even tries to send any PJSIP messages.

I'm currently running Asterisk 13.0.0.

Anyone have any suggestions as to what I am doing wrong?
The SIP provider says the latest version of Asterisk they have anyone using is Asterisk 11, so they have no PJSIP configuration experience.

The only setting that I believe I haven't found a PJSIP settting for is the "insecure=invite" from sip.conf
I thought that would be the equivalent of no authentication object, so I tried that.  However, that did not work either.

I tried changing the endpoint to have no auth and outbound_auth settings.
I tried changing the endpoint to use the auth instead of the outbound_auth.

The SIP provider even changed the username and passwords to blank.  I followed suit and changed the pjsip.conf user and password related settings to blank.

Our sip.conf (running in a different VM on Asterisk 13.0.0) settings look like this...
type = friend
qualify = no
nat = yes
host = xxxxx
defaultuser = yyyyy
secret = zzzzz
incominglimit = 4
accountcode = 9
port = 5060
context = TestApp
dtmfmode = auto
insecure = invite
fromdomain = xxxxx
fromuser = yyyyy
sendrpid = yes
trustrpid = yes
canreinvite = no

For the pjsip.conf settings (Asterisk 13.0.0), I have
type = transport
bind =
protocol = udp

type = aor
max_contacts = 1
remove_existing = yes
contact = sip:yyyyy at xxxxx:5060

type = auth
username = yyyyy
password = zzzzz

type = endpoint
context = TestApp
transport = transport1
outbound_auth = auth9
aors = xxxxx
accountcode = 9
dtmf_mode = rfc4733
device_state_busy_at = 4
;force_rport = yes                           ; also tried with this setting, but it still didn't help
rtp_symmetric = yes
rewrite_contact = yes
from_domain = xxxxxx
from_user = yyyyy
send_rpid = yes
trust_id_inbound = yes
direct_media = no

Have a great day!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20141210/a0defffa/attachment-0001.html>

More information about the asterisk-users mailing list