[asterisk-users] AGI Script not working

Gopalakrishnan N gopalakrishnan.an at gmail.com
Mon Dec 2 03:35:04 CST 2013

Library is Asterisk Perl library and module DBI. The same script working in
different machine with same Asterisk version and same Perl version. Am able
to see Tx and Rx from script.

On Mon, Dec 2, 2013 at 8:08 AM, Eric Wieling <EWieling at nyigc.com> wrote:

> Sounds like you are violating the AGI protocol.   Which Perl AGI library
> are you using?
> -----Original Message-----
> From: asterisk-users-bounces at lists.digium.com [mailto:
> asterisk-users-bounces at lists.digium.com] On Behalf Of Gopalakrishnan N
> Sent: Saturday, November 30, 2013 1:27 AM
> To: Asterisk Users Mailing List - Non-Commercial Discussion
> Subject: [asterisk-users] AGI Script not working
> I have a Perl AGI script updating some values to database like recorded
> file path, unique ID and callerid. When I run the script with test
> dialplan, its not updating to database.
> Whereas database connection is fine, when I run agi debug I see only Tx
> packets not Rx packets, firewall is also OFF.
> Any other specific reason why there is no Rx.
> The same script working in one more Asterisk machine.
> Regards
> --
> _____________________________________________________________________
> -- Bandwidth and Colocation Provided by http://www.api-digital.com --
> New to Asterisk? Join us for a live introductory webinar every Thurs:
>                http://www.asterisk.org/hello
> asterisk-users mailing list
> To UNSUBSCRIBE or update options visit:
>    http://lists.digium.com/mailman/listinfo/asterisk-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-users/attachments/20131202/3b88448e/attachment.html>

More information about the asterisk-users mailing list