[asterisk-users] asterisk 11 and no RTP

Jonathan Rose jrose at digium.com
Thu Dec 20 09:40:18 CST 2012

Jerry Geis wrote:
> I have a CentOS 6.3 machine I installed Asterisk 11, worked fine...
> I then tried to install on Cents 5.8, seemed to go fine... Then when
> I
> placed a call I got this:
> ast_rtp_instance_new: No RTP engine was found. Do you have one
> loaded?
> Did a search and found issues with ARM and this problem but did not
> help
> me, not using gtalk
> or anything. Just call between two polycom phones on local network.
> Tried looking at the config.log for rtp anything and it looks ok.
> Anyone know what might be the issue?
> Thanks,
> Jerry

Start by making sure the rtp engine module was compiled and added to
your modules directory. If you are using default directories, you can
do this with the following:

$ ls /usr/lib/asterisk/modules -l | grep res_rtp_

For me this shows two engine resources which register, those being:

-rwxr-xr-x 1 root root  990101 2012-12-19 15:25 res_rtp_asterisk.so
-rwxr-xr-x 1 root root  207519 2012-12-19 15:25 res_rtp_multicast.so

If those aren't present, and especially if res_rtp_asterisk isn't
present, you'll likely need use make menuselect to make sure they
are enabled. If they aren't fixing this could be pretty trivial. If
they are, make sure you aren't getting a build error when compiling.

If they are present (and I'm kinda guessing they are), check Asterisk's
log messages for problems with registering the RTP engines.
Specifically you are looking for log messages from rtp_engine.c which
have a form similar to:

RTP Engine '<name of engine>' failed sanity check so it was not registered."

Alternatively the register rtp engine function can fail if the engine is
already in the list, but that seems unlikely. If that IS the case, you'll
have an error more similar to:

An RTP engine with the name 'name of engine>' has already been registered."

I imagine you'll much more likely see the first one though.

I don't think we've put much effort into supporting Asterisk on ARM
platforms, so I don't really know much about the specifics on why this
would be failing. Hopefully the above helps though.

More information about the asterisk-users mailing list