[asterisk-users] Asterisk codec config issue with ALAW

garge rama garge.rama at gmail.com
Wed Aug 25 03:12:46 CDT 2010

Hi All,

I struck with codec config issue. Please suggest me if you have any idea
with codec configuration of asterisk.

I have simulated Chan phone code of asterisk to my own driver and able to
make calls between my own driver and external sip [X-lite: Configured alaw,
ulaw] using asterisks pbx.

Added ulaw, alaw, g726, and g729 codecs as capabilities of ast_channel_tech
and able to make both incoming and outgoing calls with u-law.

But not able to make outgoing call [from Phone to X-lite] with *a-law* where
as incoming call is working fine.Config files are shown below,



username = 3300

fromuser = 3300

type = friend

outboundproxy =

fromdomain =

host =

secret = 12345

qualify = no

insecure = invite

port = 5060

session-timers = refuse

context = EXT_3300

*disallow = all*


canreinvite = no

Outgoing call failed with “*No* *audio format found to offer. Cancelling
call to EXTEN*” and also some times I am seeing below print from asterisk

“*Dropping* *incompatible voice frame on Phone/1 of format unknown since our
native format has changed to 0x90c (ulaw|alaw|g726|g729)*”


   1. If I configure ast_channel_tech  capabilities as only *a-law* then I
   am not seeing this issue and able to make both incoming and outgoing calls.
   2. If I add g723 also in capabilities [ulaw, alaw, *g723*, g726, g729]
   then I am seeing set_format always selecting G723 codec and trying to do
   some translation. In this case ulaw also is not working.
   3. Tried *core show translation* from asterisk CLI and it shown all
   codecs [ulaw,alaw,g723,g726,g729….].


      -     Is any thing need to configure from conf files [sip.conf /
phone.conf: Actually I am not reading any config from phone.conf].

-          Is phone driver restricted to use only one codec at a time [I
mean, need to register only a-law as capabilities]

-          I have tried with other codec [g726] and I am facing same
outgoing issue. I will check with g729 also.

I found similar issues reported by other people also, but I did not get any
root cause for this issue. Please help me.

Thanks in advance.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.digium.com/pipermail/asterisk-users/attachments/20100825/b89217a5/attachment.htm 

More information about the asterisk-users mailing list