[asterisk-users] DNS A queries for channel

samuel samu60 at gmail.com
Tue Nov 11 03:48:05 CST 2008

2008/11/10 Matt Riddell <lists at venturevoip.com>

> On 11/11/2008 1:34 a.m., samuel wrote:
> > Folks,
> >
> > I'm tracing this error and looks like newer 1.4 (1.4.22) does not behave
> as
> > I stated (no DNS for channel domainname) and it must have been solved in
> the
> > way from my versions to the newer.
> >
> > I'll update to the newer versions and confirm it.
> Fantastic if that's the case.  I've seen quite a few people complaining
> about this and actually had an upstream DNS provider change IP :)
> All solved by a caching dns server - achieved in debian by:
>  apt-get install bind9
> followed by change nameserver to in resolv.conf

But this does not solve the problem, it's just a global work around.

Asterisk still makes the queries and if there's some problem in the DNS it
will continue blocking the first time the authoritative DNS crashes. The
problem is that since the channel is a "random string", the queries can NOT
be cached (everytime the domain name is different) and the DNS timeout still
occur for every DNS channel query and the asterisk will block at some call

So far I've updated a few machines (1.4.22) and the DNS queries are reduced
to a minimum, at least haven't seen DNS channel queries...

Anyone familiar with this knows whether this issue is solved in 1.6?

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.digium.com/pipermail/asterisk-users/attachments/20081111/571bb394/attachment.htm 

More information about the asterisk-users mailing list