[asterisk-users] asterisk as non-root/best practices

CunningPike cunningpike at gmail.com
Fri Nov 30 17:03:27 CST 2007

Is /sbin in your path?


Robert McNaught wrote:
> my problem is that a non-privileged user, eg admin, cannot log in and
> connect to the console by issuing the following
> [admin at XXXX]$ asterisk -r
> bash: asterisk: command not found
> [admin at XXXXX]$ whereis asterisk
> asterisk: /usr/sbin/asterisk /usr/lib/asterisk /usr/include/asterisk
> /usr/include/asterisk.h /usr/share/man/man8/asterisk.8
> what is the best way to solve this problem?
> i have tried adding
> admin   ALL=(ALL)       ALL    - I will prune back once I verify I can
> get this working
> into visudo, but even that returns asterisk:command not found
> Does anyone out there know the best way around this - I tried adding in
> a symbolic link in /usr/bin/asterisk to point to the
> /home/asterisk/asterisk-bin/sbin/asterisk file, which worked, but is a
> hack around the problem and don't believe this is the way
> It seems that non-privileged users cannot run commands in sbin, but can
> in bin directories
> Robert

More information about the asterisk-users mailing list