[asterisk-users] 0005162: RTP Packetization : Few questions

Dan Austin Dan_Austin at Phoenix.com
Thu Sep 7 10:24:17 MST 2006

> As far as the above is concerned I have the following:

> I am using Asterisk 1.2.10, patched with this patch for 1.2.10.
> I have 2 * boxes.  They call each other over SIP, and I have in 
> sip.conf on both boxes

> autoframing=yes
> disallow=all
> allow=g729:80

> When A calls B, it sets ptime:80.

> On B I see this:
> We're at port 11004
> Adding codec 0x100 (g729) to SDP
> Sep  7 18:16:16 WARNING[5529]: frame.c:1072 ast_codec_pref_getsize:
> Framing not set for codec g729, using default 20 and ptime:20
I'll have a look at the 1.2.10 patch

> So B is setting packetization to 20, when it should be 80, and is not 
> respecting autoframing.
Another developer wrote the autoframing feature, and I have not used
it, but I'll look to see if there is an obvious reason why it does
not find or honor the ptime.

Can you capture the SIP INVITE dialog on box B so I can see the SDP
offer, and look to see if the ptime element is present and set

> I have tried this with reinvites=yes and no, and autoframing=yes and 
> no, still the same.
Can you try with autoframing=no and force 80ms on both sides?

>>>Also, I am not sure if this is a bug.
>>>If in sip.conf, if I set
>> BUG!
>> Which version of the patch and what SVN version?  I suspect it has
>> to do with one or more of the codecs that we could not find
>> framing/packetization details about.  Is alaw the codec used in the
>> call that causes the crash?
>>>then when asterisk calls, it says I have not set Framing (like above
>> msg),
>>>then asterisk just dies.
>>>If I chane the line
>>>allow=all to allow=alaw:20
>>>then its fine, and asterisk does not die.
>>>Dont know if this is a bug, so I wont post debug/full messages now.

More information about the asterisk-users mailing list