[Asterisk-Users] SIP Connection to a Cisco AS5xxx gateway

Asterisk asterisk at openview.nextfone.us
Tue Oct 12 14:36:19 MST 2004


Here is what works for me. It is currently working and in service on an MC3810.
 
plar is needed so incoming calls ring an extension in asterisk.  extension 102 sends call to my IVR root. Please remember to configure default gateway. This especially important if you have nat specified in asterisk. 
 
This is for an MC3810, but you should be able to get enough out of it to make your AS5300 work.
 
Jojo
 
In IOS:
 
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname MC3810-1
!
boot-start-marker
boot system flash:mc3810-a2isv5-mz.123-10.bin
boot-end-marker
!
enable password 7 xxxxxxxxxxx
!
network-clock base-rate 56k
no aaa new-model
ip subnet-zero
!
no ip domain lookup
!
voice class codec 10
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 4 g729r8
 codec preference 6 g729ar8
!
no voice confirmation-tone
!
controller T1 0
 shutdown
 framing sf
 linecode ami
!
interface Ethernet0
 ip address 192.168.1.7 255.255.255.0
 ip route-cache same-interface
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
interface FR-ATM20
 no ip address
 shutdown
!
ip default-gateway 192.168.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
no ip http server
!
!
!
!
voice-port 1/2
 connection plar 102
 station-id name FXO2
 station-id number 8002
!
voice-port 1/3
 connection plar 102
 station-id name FXO3
 station-id number 8003
!
dial-peer cor custom
!
dial-peer voice 1 pots
 destination-pattern ...........
 port 1/3
!         
dial-peer voice 2 pots
 destination-pattern ...........
 port 1/2
!
dial-peer voice 10 voip
 destination-pattern 102
 voice-class codec 10
 session protocol sipv2
 session target sip-server
!
sip-ua 
 retry invite 3
 retry cancel 2
 sip-server ipv4:192.168.1.5:5060
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line 2 3
 transport preferred all
 transport output all
line vty 0 4
 password 7 xxxxxxxxx
 login
 transport preferred all
 transport input all
 transport output all
!
end
 
 
In sip.conf:
 
[8002]
type=friend
username=8002
host=192.168.1.7 <- IP address of Cisco
canreinvite=no
qualify=yes
nat=no
dtmfmode=inband
 
[8003]
type=friend
username=8003
host=192.168.1.7 <- IP address of Cisco
canreinvite=no
qualify=yes
nat=no
dtmfmode=inband
 
 
In extensions.conf
 
[default]
include => 8002

exten => 102,1,Goto(locals,s,1) <-sends to root of my IVR
 
[8002]
exten => _91NXXNXXXXXX,1,Dial(SIP/${EXTEN:1}@8002)
exten => _91NXXNXXXXXX,2,Dial(SIP/${EXTEN:1}@8003)
 
 

________________________________

From: asterisk-users-bounces at lists.digium.com on behalf of Emilio Panighetti
Sent: Tue 10/12/2004 1:14 PM
To: Asterisk Users Mailing List - Non-Commercial Discussion
Subject: [Asterisk-Users] SIP Connection to a Cisco AS5xxx gateway



Hello,

Does anybody have any experience connecting Asterisk to a Cisco gateway?
I'm trying to terminate calls into this gateway, and then route
incoming DID numbers from the gateway into Asterisk.
So far, Asterisk sends the call to the gateway, and it connects the
call, but there's no audio. I'm using the Cisco gateway with IOS
12.3.10T, connecting as SIP, no registration, and as clients I tried
different SIP Phones including Cisco ATA (which connects to the gateway
just fine without using asterisk), Gandstream ATA and the console. They
all communicate to each other through SIP, but not to the Cisco
gateway. I'm using g.711uLaw as the codec to talk to the gateway.

Thanks,
E.

_______________________________________________
Asterisk-Users mailing list
Asterisk-Users at lists.digium.com
http://lists.digium.com/mailman/listinfo/asterisk-users
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 8066 bytes
Desc: not available
Url : http://lists.digium.com/pipermail/asterisk-users/attachments/20041012/f83724cb/attachment.bin


More information about the asterisk-users mailing list