[Asterisk-Users] Cisco router for PRI termination?

Henry Devito hdevito at qwest.net
Wed Oct 6 20:48:04 MST 2004


Here is a Cisco config that should work.  I have this implemented in my lab
to make sure it would work for you.  You can reliably connect using 12.2 IOS
but more features were add in 12.3.  12.3 is the what I did this config on.

Router# show running-configuration


Building configuration...


Current configuration : 3845 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log uptime

no service password-encryption

!

boot-start-marker

boot-end-marker

!

no logging buffered

!

resource-pool disable

clock timezone GMT -6

clock summer-time GMT recurring

!


no aaa new-model

ip subnet-zero

ip tcp path-mtu-discovery

ip name-server 192.168.254.48

!

isdn switch-type primary-ni

isdn voice-call-failure 0

isdn alert-end-to-end

!

voice call send-alert

!

voice service voip

 signaling forward unconditional

 sip

!

fax interface-type fax-mail

!

controller T1 0

 framing esf

 crc-threshold 0

 clock source line primary

 linecode b8zs

 pri-group timeslots 1-24

 description lucent_pbx

!

controller T1 1

 shutdown

 framing esf

 crc-threshold 0

 linecode b8zs

 description Toshiba_pbx

!

controller T1 2

 shutdown

 framing esf

 crc-threshold 0

 linecode ami

!

controller T1 3

 framing esf

 crc-threshold 0

 clock source line secondary 1

 linecode b8zs

 pri-group timeslots 1-24

!

translation-rule 100

 Rule 1 ^1 1 ANY national

 Rule 2 2% 2 ANY unknown

 Rule 4 4% 4 ANY unknown

 Rule 5 5% 5 ANY unknown

 Rule 6 6% 6 ANY unknown

 Rule 7 7% 7 ANY unknown

 Rule 8 8% 8 ANY unknown

 Rule 9 9% 9 ANY unknown

!

interface Ethernet0

 ip address 192.168.254.254 255.255.255.0

 no ip route-cache

 no ip mroute-cache

 ip rsvp bandwidth 1 1

!

interface Serial0:23

 no ip address

 isdn switch-type primary-ni

 isdn incoming-voice modem

 isdn guard-timer 3000

 isdn supp-service name calling

 isdn disconnect-cause 1

 fair-queue 64 256 0

 no cdp enable

!

interface Serial3:23

 no ip address

 isdn switch-type primary-ni

 isdn protocol-emulate network

 isdn incoming-voice modem

 isdn guard-timer 3000

 isdn supp-service name calling

 isdn T310 30000

 isdn disconnect-cause 1

 isdn bchan-number-order descending

 fair-queue 64 256 0

 no cdp enable

!

interface FastEthernet0

 ip address 192.168.254.2 255.255.255.0

 no ip route-cache

 no ip mroute-cache

 duplex auto

 speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.193.1

ip route 0.0.0.0 0.0.0.0 192.168.193.189

ip route 0.0.0.0 0.0.0.0 Ethernet0

ip route 10.2.0.1 255.255.255.255 192.168.254.135

ip route 172.18.0.0 255.255.0.0 Ethernet0

no ip http server

!

map-class dialer test

 dialer voice-call

dialer-list 1 protocol ip permit

!

control-plane

!

voice-port 0:D

!

dial-peer voice 10 pots

 application session.t.old

 destination-pattern 5550100

 prefix 5550100

!

dial-peer voice 4 voip

 application session

 destination-pattern 5550120

 session protocol sipv2

 session target ipv4:192.168.254.20

 incoming called-number 5550125

!

dial-peer voice 1 pots

 application session

 destination-pattern 5550125

 incoming called-number 5550155

 port 0:D

 prefix 95550125

!

dial-peer voice 18 voip

 application session

 destination-pattern 36601

 session protocol sipv2

 session target ipv4:192.168.254.17

 codec g711ulaw

!

dial-peer voice 25 voip

 destination-pattern 5550155

 session protocol sipv2

 session target ipv4:192.168.254.101

!

dial-peer voice 5678 pots

 destination-pattern 5678

 port 3:D

 prefix 5678

!

dial-peer voice 56781 voip

 incoming called-number 5678

!

sip-ua
 retry invite 3
 retry response 3
 retry bye 3
 retry cancel 3
 timers trying 1000
 sip-server ipv4:x.x.x.x -optional
!

line con 0

line aux 0

line vty 0 4

 password lab

 login

!

end



-----Original Message-----
From: asterisk-users-bounces at lists.digium.com
[mailto:asterisk-users-bounces at lists.digium.com] On Behalf Of Bruce Komito
Sent: Wednesday, October 06, 2004 10:14 PM
To: asterisk-users at lists.digium.com
Subject: [Asterisk-Users] Cisco router for PRI termination?

If you have a PRI terminated in a Cisco router talking SIP to * and would
be willing to share your Cisco config, please respond.  Also, I would be
interested in knowing what version of IOS you are using.  We are using an
NM-HDV in a 3640.

TIA

Bruce Komito
High Sierra Networks, Inc.
www.servers-r-us.com
(775) 236-5815


_______________________________________________
Asterisk-Users mailing list
Asterisk-Users at lists.digium.com
http://lists.digium.com/mailman/listinfo/asterisk-users
To UNSUBSCRIBE or update options visit:
   http://lists.digium.com/mailman/listinfo/asterisk-users




More information about the asterisk-users mailing list