[Asterisk-Users] RE: Asterisk problem

T. Chan tommy.chan at utimail.com
Wed Dec 17 22:32:12 MST 2003

Dear All,

I am a new user of Asterisk interested in setting up a VOIP network based on
Asterisk. I have deployed a few Asterisk servers running on T400P and have
started a few weeks ago to run some LIVE traffic on one of the servers. Most
of my current traffic is via H323 to and from other carriers / customers and
I am using the H323 driver written by Jeremy of Nufone.

I have had problems with this, as it seems that as time goes, for instance
after 5 or 6 hours or sometimes 3 to 4 hours or less, the system would not
be able to take any incoming calls via H323 protocol. All the calls from my
H323 customers (they are mostly carriers sending traffic to me from other
gateways such as cisco AS5300) would be rejected and the system just would
not take the calls for some reasons. I could, however, call into the PRI
(Zap interface) and make an outbound H323 calls to other gateways of my
carriers. That is, incoming H323 calls would not work after a certain period
of operation time but outgoing H323 calls would still be possible.

I tried running the asterisk -vvvgcd in some cases in order to capture any
possible error messages and I was fortunate to be looking at it when it
started to fail once and have received twice this message on the screen:

ThreadID=0x001d4c25 assert.cxx(105) PWLib Assertion fail: Operating System
error, file tlibthrd.cxx, Line 644 Error=24

I have got this twice, one about 10 seconds after the other, and then I
tried calling into the system via H323 and it wouldn't take my calls. Ladies
and gentlemen,  do you have any idea what it is and how can I get rid of
this problem because it is doing it every like 2 to 6 hours and is killing

I have then downloaded newer version of the Asterisk about 10 days ago, but
then my Asterisk would start to crash on me, the module would just stop
running by itself and I had to restart the Asterisk. Sometimes, it would
just stop running, but 75% of the time, I would see this error message:

Connected to Asterisk CVS-12/06/03-03:06:28 currently running on localhost
(pid = 23720)
    -- Remote UNIX connection
localhost*CLI> /usr/sbin/safe_asterisk: line 6: 23720 Segmentation fault
asterisk ${ASTARGS} 1>&/dev/${TTY} </dev/${TTY}
Asterisk ended with exit status 139
Asterisk exited on signal 11.
Automatically restarting Asterisk.

Disconnected from Asterisk server
Executing last minute cleanups
[root at localhost asterisk]# /usr/sbin/safe_asterisk: line 6: 23752
Segmentation fault      asterisk ${ASTARGS} 1>&/dev/${TTY} </dev/${TTY}
Asterisk ended with exit status 139
Asterisk exited on signal 11.
Automatically restarting Asterisk.

It seems that it would try to restart but would fail, and then I had to
restart it manually. This Segmentation error happens only with new version
of Asterisk but not with older version (10 days ago), does anyone here have
any of such experience or know why this is happening? Is this because I am
running T400P instead of TE410P hardware and that the newer version of
software is not 100% compatible with the old hardware? The inbound H323
problem, however, exists for both the newer and older version of Asterisk,
and I wonder if anyone has had this experience before. Is this pertaining to
the hardware as well or is there any other reason/

Ladies and Gentlemen, any feedbacks and advices would be appreciated. Many

Tommy Chan 

Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.547 / Virus Database: 340 - Release Date: 12/2/2003
-------------- next part --------------
A non-text attachment was scrubbed...
Name: winmail.dat
Type: application/ms-tnef
Size: 3740 bytes
Desc: not available
Url : http://lists.digium.com/pipermail/asterisk-users/attachments/20031217/abbb00a0/winmail.bin

More information about the asterisk-users mailing list