[asterisk-ss7] T38 fax issue

Kaloyan Kovachev kkovachev at varna.net
Fri Aug 22 08:52:44 CDT 2014

in addition to FAXOPT(gateway) you may try to request transmission 
medium from telco - see SS7_TMR or SS7_TMR_NUM, as it should be set on 
the outgoing (dahdi) channel you need to set it on the SIP channel with 
underscore (_SS7_TMR)

The possible options are defined in libss7.h and SS7_TMR_3K1_AUDIO (or 3 
as num) works fine here. If you can detect the fax calls you may request 
64K_UNRESTRICTED data for them

On 2014-08-22 15:47, Huseyin Kaya wrote:

> Hello
> I am using Sangoma A104DE with libss7 on Asterisk 11.5.0 and 
> terminating calls to telco with ss7 . We are using patched version of 
> Libss7 that have timers 
> functionality.(https://issues.asterisk.org/jira/browse/SS7-27)
> The server is on production for the last 6 months and everything was 
> fine
> My interconnection with telco is only one way. From sip to ss7 .
> Everything is fine except one thing.
> One of my customers asked for t38 faxing. then i found myself in 
> trouble.
> I get several sip traces and found the problem at the end .When i 
> receive an invite T38 , asterisk is sending 200 OK message but in SDP 
> it is sending g711u,g711a,g729 as codecs. So after this point 
> everything is messed up.
> I tried to set t38pt_udptl=no in sip.conf , but still asterisk is 
> sending sip 200 ok with sdp g711...
> ı tried to set t38pt_udptl = yes,redundancy,maxdatagram=400 and 
> setvar=FAXOPT(gateway)=yes,20 in sip.conf but still i couldn't manage 
> to receive fax
> So basically what i need to send fax from sip to telco but could not 
> manage to do till now.
> Everything except fax is working like a charm.
> Is anyone succeed to handle fax with libss7.
> I will be glad if an expert can show me a way to achive this.
> Best Regards

More information about the asterisk-ss7 mailing list