[asterisk-ss7] Audio Lost problem

Anton anton.vazir at gmail.com
Mon Mar 13 12:46:00 MST 2006

Hi guys,

I've done tons of experiments with chan_ss7 and my 
impression of having audio lost problem is that there is 
some mis-clocking issue. When there are calls over g711 
codecs from the SS7 PC - I do not have Audio Lost trouble. 
And mostly that happens on the long latency links 
(satellite 600ms+) so right now I'm trying to get it 
working woth external codec translator via SIP->H323 with 
parallel translation form G711->g729 - so that's works. I 
guess that sifira guys also do not use the 723/729 codecs 
on the SS7 PC - so they did not experienced the trouble.
So the partial solution - is to use a distributed system 
with SS7-VOIP on different PC's

I've tried to replace SIFIRA ss7_write code with the code 
similar to used in chan_zap -> with almost the same result 
(although with a little better behaviour, i think binded 
with the fact that in chan_zap the code does not attempt to 
write more than 160 bytes at once to the ZAP in the cycle)

Any similar experience?

More information about the asterisk-ss7 mailing list