<html>
<body>
<div style="font-family: Verdana, Arial, Helvetica, Sans-Serif;">
<table bgcolor="#f9f3c9" width="100%" cellpadding="8" style="border: 1px #c9c399 solid;">
<tr>
<td>
This is an automatically generated e-mail. To reply, visit:
<a href="https://reviewboard.asterisk.org/r/3173/">https://reviewboard.asterisk.org/r/3173/</a>
</td>
</tr>
</table>
<br />
<pre style="white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">So, I have some comments / concerns about the 'refactor' of chan_sip. Basically, why are we doing it? I mean, now that chan_pjsip.c exists, I would very much like to see actually development of chan_sip.c stop and be focused on chan_pjsip. Reason being, when ever we do refactor / add new features to chan_sip, we end up breaking something.
I know chan_pjsip is not feature par with chan_sip, however we should avoid reworking it when possible.
Thoughts?</pre>
<br />
<p>- Paul Belanger</p>
<br />
<p>On February 3rd, 2014, 7:48 p.m. UTC, Corey Farrell wrote:</p>
<table bgcolor="#fefadf" width="100%" cellspacing="0" cellpadding="8" style="background-image: url('https://reviewboard.asterisk.org/static/rb/images/review_request_box_top_bg.ab6f3b1072c9.png'); background-position: left top; background-repeat: repeat-x; border: 1px black solid;">
<tr>
<td>
<div>Review request for Asterisk Developers.</div>
<div>By Corey Farrell.</div>
<p style="color: grey;"><i>Updated Feb. 3, 2014, 7:48 p.m.</i></p>
<div style="margin-top: 1.5em;">
<b style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Bugs: </b>
<a href="https://issues.asterisk.org/jira/browse/ASTERISK-22582">ASTERISK-22582</a>
</div>
<div style="margin-top: 1.5em;">
<b style="color: #575012; font-size: 10pt;">Repository: </b>
Asterisk
</div>
<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Description </h1>
<table width="100%" bgcolor="#ffffff" cellspacing="0" cellpadding="10" style="border: 1px solid #b8b5a0">
<tr>
<td>
<pre style="margin: 0; padding: 0; white-space: pre-wrap; white-space: -moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; word-wrap: break-word;">Isolates code that manages struct sip_route.
* Move route code to sip/route.c + sip/include/route.h
* Rename functions to sip_route_*
* Replace ad-hoc list code with macro's from linkedlists.h
* Create sip_route_process_header() to processes Path and Record-Route headers (previously done with different code in build_route and build_path)
* Make sip_route uri accessor return a const
* Move struct uriparams, struct contact and contactliststruct from sip.h to reqresp_parser.h. sip/route.c uses reqresp_parser.h but not sip.h, this was a problem. These moved declares are not used outside of reqresp_parser.
* While modifying reqprep() the lack of {} caused me trouble. I added them.
* Code outside route.c treats sip_route as an opaque structure, using macro's or procedures for all access.</pre>
</td>
</tr>
</table>
<h1 style="color: #575012; font-size: 10pt; margin-top: 1.5em;">Diffs</b> </h1>
<ul style="margin-left: 3em; padding-left: 0;">
<li>/trunk/channels/sip/route.c <span style="color: grey">(PRE-CREATION)</span></li>
<li>/trunk/channels/sip/include/sip.h <span style="color: grey">(407178)</span></li>
<li>/trunk/channels/sip/include/route.h <span style="color: grey">(PRE-CREATION)</span></li>
<li>/trunk/channels/sip/include/reqresp_parser.h <span style="color: grey">(407178)</span></li>
<li>/trunk/channels/chan_sip.c <span style="color: grey">(407178)</span></li>
</ul>
<p><a href="https://reviewboard.asterisk.org/r/3173/diff/" style="margin-left: 3em;">View Diff</a></p>
</td>
</tr>
</table>
</div>
</body>
</html>