[asterisk-dev] ODBC and commas

Nikša Baldun it at voxdiversa.hr
Mon Aug 16 12:08:18 CDT 2021

OK, false alarm (sort of). I am using AEL, which apparently always wraps 
the right side of assignment in $[], which messes things up. This 
doesn't work with commas in db field:


but this does:


It seems that AEL native syntax can't be used with ODBC_FETCH. Perhaps 
this helps someone in the future.

On 15. 08. 2021. 16:06, Nikša Baldun wrote:
> Tried QUOTE() where? I don't see where it can be applied.
> On 15. 08. 2021. 09:29, Dennis Buteyn wrote:
>> On 8/13/21 9:51 AM, Nikša Baldun wrote:
>>> Hello,
>>> does anyone know, what is the recommended way to handle commas with 
>>> func_odbc? There is a parameter “escapecommas” in func_odbc.conf, 
>>> but regardless of its value, having a comma in DB field breaks 
>>> ODBC_FETCH function. The text after the comma is assigned to the 
>>> next field instead of the current one.
>>> Best regards.
>> Have you tried QUOTE()?
>> -- 
>> Dennis Buteyn
>> Xorcom Ltd
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20210816/6d99bf74/attachment.html>

More information about the asterisk-dev mailing list