[asterisk-dev] [Code Review] 3768: ARI: add a copy operation for stored recordings

Samuel Galarneau reviewboard at asterisk.org
Mon Jul 14 13:19:37 CDT 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/3768/#review12631
-----------------------------------------------------------


Working well against my working copy of the 12 branch. Tested copying from various folder structures to other ones and deleting copied recordings as well as ensuring that resulting audio is a proper copy of the original.


/branches/12/rest-api/api-docs/recordings.json
<https://reviewboard.asterisk.org/r/3768/#comment22908>

    I would prefer to see destinationRecordingName here.
    
    Ideally we could just call it destination and rename recordingName to name since we know we're dealing with the recording resource but we should stick to recordingName and destinationRecordingName to match the other operations on the recording resource.


- Samuel Galarneau


On July 14, 2014, 12:57 p.m., Matt Jordan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/3768/
> -----------------------------------------------------------
> 
> (Updated July 14, 2014, 12:57 p.m.)
> 
> 
> Review request for Asterisk Developers and Samuel Galarneau.
> 
> 
> Bugs: ASTERISK-24036
>     https://issues.asterisk.org/jira/browse/ASTERISK-24036
> 
> 
> Repository: Asterisk
> 
> 
> Description
> -------
> 
> This patch adds a new operation for stored recordings, copy. It takes an existing stored recording and makes a copy of it in the same directory or a relative directory under the stored recording directory.
> 
> /ari/recordings/stored/{recordingName}/copy?dstRecordingName={copy_name}
> 
> This is particularly useful for voicemail-esque applications, which may need to copy or move recordings around a directory structure.
> 
> 
> Diffs
> -----
> 
>   /branches/12/rest-api/api-docs/recordings.json 418463 
>   /branches/12/res/stasis_recording/stored.c 418463 
>   /branches/12/res/res_ari_recordings.c 418463 
>   /branches/12/res/ari/resource_recordings.c 418463 
>   /branches/12/res/ari/resource_recordings.h 418463 
>   /branches/12/include/asterisk/stasis_app_recording.h 418463 
>   /branches/12/CHANGES 418463 
> 
> Diff: https://reviewboard.asterisk.org/r/3768/diff/
> 
> 
> Testing
> -------
> 
> Automated tests were written for the Asterisk Test Suite, and are on review https://reviewboard.asterisk.org/r/3769
> 
> 
> Thanks,
> 
> Matt Jordan
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20140714/d1334bf9/attachment-0001.html>


More information about the asterisk-dev mailing list