[asterisk-dev] [Code Review] 3173: chan_sip refactor - sip_route

Corey Farrell reviewboard at asterisk.org
Mon Feb 3 08:10:16 CST 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/3173/
-----------------------------------------------------------

(Updated Feb. 3, 2014, 9:10 a.m.)


Review request for Asterisk Developers.


Bugs: ASTERISK-22582
    https://issues.asterisk.org/jira/browse/ASTERISK-22582


Repository: Asterisk


Description
-------

Isolates code that manages struct sip_route.

* Move route code to sip/route.c + sip/include/route.h
* Rename functions to sip_route_*
* Replace ad-hoc list code with macro's from linkedlists.h
* Create sip_route_process_header() to processes Path and Record-Route headers (previously done with different code in build_route and build_path)
* Make sip_route uri accessor return a const
* Move struct uriparams, struct contact and contactliststruct from sip.h to reqresp_parser.h.  sip/route.c uses reqresp_parser.h but not sip.h, this was a problem.  These moved declares are not used outside of reqresp_parser.
* While modifying reqprep() the lack of {} caused me trouble.  I added them.
* Code outside route.c treats sip_route as an opaque structure, using macro's or procedures for all access.


Diffs (updated)
-----

  /trunk/channels/sip/route.c PRE-CREATION 
  /trunk/channels/sip/include/sip.h 407178 
  /trunk/channels/sip/include/route.h PRE-CREATION 
  /trunk/channels/sip/include/reqresp_parser.h 407178 
  /trunk/channels/chan_sip.c 407178 

Diff: https://reviewboard.asterisk.org/r/3173/diff/


Testing
-------


Thanks,

Corey Farrell

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20140203/fb04708c/attachment.html>


More information about the asterisk-dev mailing list