[asterisk-dev] [Code Review] 3173: chan_sip refactor - sip_route

wdoekes reviewboard at asterisk.org
Mon Feb 3 07:26:00 CST 2014


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/3173/#review10741
-----------------------------------------------------------

Ship it!


The code looks nice and clean to me.

I ticked the ship-it, but a second pair of eyes on it can't hurt.

A few minor nitpicks below.


/trunk/channels/chan_sip.c
<https://reviewboard.asterisk.org/r/3173/#comment20234>

    Add the {} braces while you're touching this.



/trunk/channels/sip/include/route.h
<https://reviewboard.asterisk.org/r/3173/#comment20235>

    A bit uncommon to have the unknown between the known values.



/trunk/channels/sip/route.c
<https://reviewboard.asterisk.org/r/3173/#comment20236>

    Braces here too. Coding guidelines mandate it.



/trunk/channels/sip/route.c
<https://reviewboard.asterisk.org/r/3173/#comment20238>

    const struct sip_route ?



/trunk/channels/sip/route.c
<https://reviewboard.asterisk.org/r/3173/#comment20237>

    const struct sip_route ?



/trunk/channels/sip/route.c
<https://reviewboard.asterisk.org/r/3173/#comment20239>

    const struct sip_route ?



/trunk/channels/sip/route.c
<https://reviewboard.asterisk.org/r/3173/#comment20240>

    const struct sip_route ?


- wdoekes


On Feb. 3, 2014, 12:41 p.m., Corey Farrell wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/3173/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2014, 12:41 p.m.)
> 
> 
> Review request for Asterisk Developers.
> 
> 
> Bugs: ASTERISK-22582
>     https://issues.asterisk.org/jira/browse/ASTERISK-22582
> 
> 
> Repository: Asterisk
> 
> 
> Description
> -------
> 
> Isolates code that manages struct sip_route.
> 
> * Move route code to sip/route.c + sip/include/route.h
> * Rename functions to sip_route_*
> * Replace ad-hoc list code with macro's from linkedlists.h
> * Create sip_route_process_header() to processes Path and Record-Route headers (previously done with different code in build_route and build_path)
> * Make sip_route uri accessor return a const
> * Move struct uriparams, struct contact and contactliststruct from sip.h to reqresp_parser.h.  sip/route.c uses reqresp_parser.h but not sip.h, this was a problem.  These moved declares are not used outside of reqresp_parser.
> * While modifying reqprep() the lack of {} caused me trouble.  I added them.
> * Code outside route.c treats sip_route as an opaque structure, using macro's or procedures for all access.
> 
> 
> Diffs
> -----
> 
>   /trunk/channels/sip/route.c PRE-CREATION 
>   /trunk/channels/sip/include/sip.h 407178 
>   /trunk/channels/sip/include/route.h PRE-CREATION 
>   /trunk/channels/sip/include/reqresp_parser.h 407178 
>   /trunk/channels/chan_sip.c 407178 
> 
> Diff: https://reviewboard.asterisk.org/r/3173/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Corey Farrell
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20140203/7593d71d/attachment-0001.html>


More information about the asterisk-dev mailing list