[asterisk-dev] problem in cross compiling asterisk

Mohammed Essaid Mezerreg moh.essaid at gmail.com
Mon Apr 28 08:27:11 CDT 2014

no, I am not using FreeBSD, I am using CentOS 6.5, and I tried to omit the
-lresolv but it didn't work but lot of errors keep showing off because of
this changement. I am using the uClibc toolchains from opencores to achieve
this coss compiling process and before this error I encountred lot of some
other errors like this one which prove that asterisk don't support uclibc

I had some error in compiling ael_lex the errors comes from the ael.flex in
this line:

   [CC] ael/ael_lex.c -> ael/ael_lex.o
ael.flex: In function ‘ael_yylex’:
ael.flex:601:43: error: ‘GLOB_BRACE’ undeclared (first use in this function)
ael.flex:601:43: note: each undeclared identifier is reported only once for
each function it appears in
make[1]: *** [ael/ael_lex.o] Error 1
make: *** [res] Error 2

and when I looked in the ael.flex I find this:

#ifdef SOLARIS
            glob_ret = glob(fnamebuf, GLOB_NOCHECK, NULL, &globbuf);
            glob_ret = glob(fnamebuf, GLOB_NOMAGIC|GLOB_BRACE, NULL,

and the else block is the place where the compilation stack and when I went
to the configuration result I found that the checking action fro

after that I went to the glob.h header in my toolchain to find this line:

#if 1 /* uClibc gnu glob does not support these */
# define GLOB_ALTDIRFUNC (1 << 9)/* Use gl_opendir et al functions.  */
# define GLOB_BRACE     (1 << 10)/* Expand "{a,b}" to "a" "b".  */
# define GLOB_NOMAGIC     (1 << 11)/* If no magic chars, return the
pattern.  */
# define GLOB_TILDE     (1 << 12)/* Expand ~user and ~ to home directories.
# define GLOB_ONLYDIR     (1 << 13)/* Match only directories.  */
# define GLOB_TILDE_CHECK (1 << 14)/* Like GLOB_TILDE but return an error
                      if the user name is not available.  */

so these constant are not supported by uClibc which mean that asterisk
didn't treat uclibc cases or in another way asterisk still don't support

I solved this problem anyway but still the problem in linking the asterisk
object in the end of the process
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20140428/60da3545/attachment.html>

More information about the asterisk-dev mailing list