[asterisk-dev] [Code Review] Changes from Mantis ID 13495 in trunk.
rmudgett
reviewboard at asterisk.org
Mon Oct 1 16:20:54 CDT 2012
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/1676/#review7178
-----------------------------------------------------------
Please create a new libss7 review for the libss7 patch. I cannot comment on it. The ISUP_SET_OUT flag name is not descriptive of what it does.
This review is also getting sluggish because of its size. You should be able to create a new review against the ss7_27_knk branch. Reviewboard is fussy about the branch names. This might work when you create the new review and need to specify the branch name: /team/rmudgett/ss7_27_knk/
trunk/channels/sig_ss7.c
<https://reviewboard.asterisk.org/r/1676/#comment13849>
The isup_init_call() should be merged into the isup_new_call(). Then the function signature would be:
struct isup_call *isup_new_call(struct ss7 *ss7, int cic, unsigned int dpc);
The adding of the new parameter to isup_init_call() is not a good idea. It would be better to add a new call to indicate that there is a pending IAM for the isup_call.
void isup_call_pending(struct isup_call *call);
trunk/channels/sig_ss7.c
<https://reviewboard.asterisk.org/r/1676/#comment13847>
This line does not belong here. Simply moving lines blindly does not work. The lines must be adapted to their new location in the code.
At this point, the p->do_hangup should be set to SS7_HANGUP_DO_NOTHING since if ast_hangup() is called on the channel before the IAM is sent, there is noting to do.
trunk/channels/sig_ss7.c
<https://reviewboard.asterisk.org/r/1676/#comment13848>
Need to also check if the soft-hangup flags were set here to abort the outgoing call. sig_ss7_cb_hangup() sets the AST_SOFTHANGUP_DEV flag on a collision.
Right before the IAM is sent near the end of sig_ss7_call(), the p->do_hangup should be set to SS7_HANGUP_SEND_REL.
- rmudgett
On Sept. 25, 2012, 9:52 a.m., KNK wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/1676/
> -----------------------------------------------------------
>
> (Updated Sept. 25, 2012, 9:52 a.m.)
>
>
> Review request for Asterisk Developers.
>
>
> Summary
> -------
>
> chan_dahdi / sig_ss7 part of changes
>
>
> This addresses bug SS7-27.
> https://issues.asterisk.org/jira/browse/SS7-27
>
>
> Diffs
> -----
>
> trunk/channels/sig_ss7.c 373581
> trunk/channels/sig_ss7.h 373581
> trunk/channels/chan_dahdi.c 373581
> trunk/configs/chan_dahdi.conf.sample 373581
> trunk/configs/ss7.timers.sample PRE-CREATION
> trunk/configure.ac 373581
>
> Diff: https://reviewboard.asterisk.org/r/1676/diff
>
>
> Testing
> -------
>
> compiles, link setup, cli commands, bassic calls, connected line and redirection.
>
>
> Thanks,
>
> KNK
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-dev/attachments/20121001/202b7e6d/attachment-0001.htm>
More information about the asterisk-dev
mailing list