[asterisk-dev] [svn-commits] jrose: trunk r347903 - /trunk/apps/app_mixmonitor.c

Kevin P. Fleming kpfleming at digium.com
Thu Dec 15 16:02:32 CST 2011

On 12/13/2011 02:24 AM, Olle E. Johansson wrote:
> 13 dec 2011 kl. 00:24 skrev David Vossel:
>> ----- Original Message -----
>>> From: "Olle E. Johansson"<oej at edvina.net>
>>> To: "SVN commits to the Digium repositories"<svn-commits at lists.digium.com>
>>> Cc: asterisk-commits at lists.digium.com
>>> Sent: Saturday, December 10, 2011 4:40:59 AM
>>> Subject: Re: [asterisk-dev] [svn-commits] jrose: trunk r347903 -	/trunk/apps/app_mixmonitor.c
>>> 9 dec 2011 kl. 22:47 skrev SVN commits to the Digium repositories:
>>>> 	res |= ast_manager_register_xml("MixMonitor", 0,
>>>> 	manager_mixmonitor);
>>>> +	res |= ast_manager_register_xml("StopMixMonitor", 0,
>>>> manager_stop_mixmonitor);
>>> Even if you disregard my wishes, can you please change to
>>> "MixMonitorStop" so they come up next to each other when you run
>>> "manager show commands".
>> Why would we do this?  How does it make sense for us to have an application called "StopMixMonitor" but the AMI action "MixMonitorStop"?
> Why repeat a mistake?

When the mistake was made years ago, and has set a precedent, there's a 
good reason for following that precedent, as long as it isn't harmful or 
misleading. If we had made the AMI action "MixMonitorStop", I could 
clearly foresee a new AMI application developer next year ranting on 
this list about the inconsistency of "StopMonitor" and "MixMonitorStop".

If there is a desire to reform AMI to have a complete consistent (and 
parameter-based) syntax, that could be done by creating a new AMI 
version with that syntax.

Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
Jabber: kfleming at digium.com | SIP: kpfleming at digium.com | Skype: kpfleming
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
Check us out at www.digium.com & www.asterisk.org

More information about the asterisk-dev mailing list