[asterisk-dev] [Code Review] IPv6 in Asterisk

Tilghman Lesher tlesher at digium.com
Fri Jun 25 22:41:07 CDT 2010


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviewboard.asterisk.org/r/743/#review2288
-----------------------------------------------------------



/trunk/include/asterisk/netsock2.h
<https://reviewboard.asterisk.org/r/743/#comment4803>

    I think this might actually be better as a union between the two sockaddr types, so that we could avoid having to do conversions all over the place and instead just do the conversions directly.  If you disagree, could you comment on this a bit further?



/trunk/include/asterisk/netsock2.h
<https://reviewboard.asterisk.org/r/743/#comment4797>

    Any reason this couldn't simply be:
    memcpy(dst, src, sizeof(*dst))?
    It's not like we're doing any byte ordering conversions here.



/trunk/include/asterisk/netsock2.h
<https://reviewboard.asterisk.org/r/743/#comment4798>

    Per convention, 1 << 0, 1 << 1, 1 << 2.  This prevents errors in the future, when getting into the higher ranges of bitwise operations.



/trunk/main/config.c
<https://reviewboard.asterisk.org/r/743/#comment4800>

    Red blob.



/trunk/main/config.c
<https://reviewboard.asterisk.org/r/743/#comment4799>

    Is this a TODO for the future or something that was merely missed?



/trunk/main/http.c
<https://reviewboard.asterisk.org/r/743/#comment4801>

    Instead of doing this conversion, does it make more sense merely to convert directly to the output format?



/trunk/main/http.c
<https://reviewboard.asterisk.org/r/743/#comment4802>

    Convention:  should these be initialized at declaration time?



/trunk/main/netsock2.c
<https://reviewboard.asterisk.org/r/743/#comment4804>

    This appears to be an opencode of the ast_str_* dynamic string implementation.  We already have ast_str_thread_get() and it probably should be used here.



/trunk/main/netsock2.c
<https://reviewboard.asterisk.org/r/743/#comment4805>

    ast_copy_string, please



/trunk/main/netsock2.c
<https://reviewboard.asterisk.org/r/743/#comment4806>

    ast_copy_string



/trunk/main/netsock2.c
<https://reviewboard.asterisk.org/r/743/#comment4807>

    The number of casts in this module seems to be a good case for putting a union within struct ast_sockaddr.  Casts can be quite error-prone.


- Tilghman


On 2010-06-25 09:02:18, Simon Perreault wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviewboard.asterisk.org/r/743/
> -----------------------------------------------------------
> 
> (Updated 2010-06-25 09:02:18)
> 
> 
> Review request for Asterisk Developers and Mark Michelson.
> 
> 
> Summary
> -------
> 
> This is the port of Asterisk to IPv6.
> 
> 
> Diffs
> -----
> 
>   /trunk/addons/chan_ooh323.c 272524 
>   /trunk/apps/app_externalivr.c 272524 
>   /trunk/channels/chan_gtalk.c 272524 
>   /trunk/channels/chan_h323.c 272524 
>   /trunk/channels/chan_iax2.c 272524 
>   /trunk/channels/chan_jingle.c 272524 
>   /trunk/channels/chan_mgcp.c 272524 
>   /trunk/channels/chan_multicast_rtp.c 272524 
>   /trunk/channels/chan_sip.c 272524 
>   /trunk/channels/chan_skinny.c 272524 
>   /trunk/channels/chan_unistim.c 272524 
>   /trunk/channels/sip/dialplan_functions.c 272524 
>   /trunk/channels/sip/include/dialog.h 272524 
>   /trunk/channels/sip/include/globals.h 272524 
>   /trunk/channels/sip/include/reqresp_parser.h 272524 
>   /trunk/channels/sip/include/sip.h 272524 
>   /trunk/channels/sip/reqresp_parser.c 272524 
>   /trunk/include/asterisk/acl.h 272524 
>   /trunk/include/asterisk/config.h 272524 
>   /trunk/include/asterisk/dnsmgr.h 272524 
>   /trunk/include/asterisk/netsock2.h PRE-CREATION 
>   /trunk/include/asterisk/rtp_engine.h 272524 
>   /trunk/include/asterisk/tcptls.h 272524 
>   /trunk/main/acl.c 272524 
>   /trunk/main/app.c 272524 
>   /trunk/main/config.c 272524 
>   /trunk/main/dnsmgr.c 272524 
>   /trunk/main/http.c 272524 
>   /trunk/main/manager.c 272524 
>   /trunk/main/netsock2.c PRE-CREATION 
>   /trunk/main/rtp_engine.c 272524 
>   /trunk/main/tcptls.c 272524 
>   /trunk/res/res_rtp_asterisk.c 272524 
>   /trunk/res/res_rtp_multicast.c 272524 
> 
> Diff: https://reviewboard.asterisk.org/r/743/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Simon
> 
>




More information about the asterisk-dev mailing list