[asterisk-dev] Re Naming of core functions --- : [svn-commits] eliel: branch group/appdocsxml r151872

Russell Bryant russell at digium.com
Fri Oct 24 07:11:01 CDT 2008

On Oct 24, 2008, at 6:55 AM, Johansson Olle E wrote:

> 24 okt 2008 kl. 12.44 skrev SVN commits to the Digium repositories:
>> - Almost all the functions related to parsing XML documentation are
>> of the form: xmldoc_*
>> - Every function that parse an entire final tag like [Synopsis],
>> [Arguments], [Description], [Syntax] and [See Also] are of the form:
>> xmldoc_build_*
> Isn't it a recommendation to have ast_ in front of all common core
> functions?
> ast_xdoc?

You are correct.  However, these are not functions that are exposed as  
part of the public API, so that requirement doesn't stand.  He was  
just setting a naming convention for the internal helper functions.

Russell Bryant
Senior Software Engineer
Open Source Team Lead
Digium, Inc.

More information about the asterisk-dev mailing list