[asterisk-dev] compling asterisk with uclibc 0.9.29

Ming-Ching Tiew mctiew at yahoo.com
Fri Oct 17 05:05:56 CDT 2008

I have been using asterisk ( eg ) with uclibc-0.9.28 all the while and it has been working.

But recently I feel that there is a need for me to check out uclibc-0.9.29. But after I compile asterisk against uclibc-0.9.29, if I run asterisk with :-

   # asterisk

The prompt will return, but process listing shows asterisk has created 3 threads ( or processes ) ( I can't tell for sure because when I am using old linux thread, each thread appears as a process ) and it will block there forever and there is no /var/run/asterisk.ctl created.

However, if I run it with :-

   # asterisk -v

The prompt will never return, but there is a /var/run/asterisk.ctl created and from the process listing, I could see that there are many many asterisk threads/processes created.

Because the uclibc has many tweakable CONFIG options, I am pretty sure it is one of the options which causes this behaviour. Anyone has idea at which point that asterisk is blocking at ?


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the asterisk-dev mailing list