[asterisk-dev] H323 64 bit Nightmare

Venefax venefax at gmail.com
Thu May 22 19:30:51 CDT 2008

Can you elaborate about the -fPIC? I exported 
export CFLAGS="-fPIC" 
and also tried ./configure -CFLAGS=-fPIC
but the problem is getting worse. Now I cannot even compile Asterisk. I get
the same error when compiling curl.

-----Original Message-----
From: asterisk-dev-bounces at lists.digium.com
[mailto:asterisk-dev-bounces at lists.digium.com] On Behalf Of Patrick
Sent: Thursday, May 22, 2008 7:35 PM
To: Asterisk Developers Mailing List
Subject: Re: [asterisk-dev] H323 64 bit Nightmare

On Thu, 2008-05-22 at 12:55 -0400, Venefax wrote:
> I downloaded the latest version as instructed and I get this error after I
> issue a 
> ./configure
> make clean opt
> o  /usr/src/ptlib_v1_12_0/lib/obj_linux_x86_64_r/collect.o
> /usr/src/ptlib_v1_12_0/lib/obj_linux_x86_64_r/contain.o
> /usr/src/ptlib_v1_12_0/lib/obj_linux_x86_64_r/object.o  -lldap -llber
> -lldap_r  -lpthread -lsasl2 -lssl -lcrypto -lexpat -lodbc -lresolv
> /usr/bin/ld:
> .a(res_comp.o): relocation R_X86_64_32 against `a local symbol' can not be
> used when making a shared object; recompile with -fPIC
Did you add -fPIC to the CFLAGS in the Makefile as suggested?


--Bandwidth and Colocation Provided by http://www.api-digital.com--

asterisk-dev mailing list
To UNSUBSCRIBE or update options visit:

More information about the asterisk-dev mailing list