[asterisk-dev] SIP with canreinvite=yes through multiple Asterisk instances

Edwin Groothuis edwin at mavetju.org
Thu Aug 16 07:44:20 CDT 2007

The story at http://www.mavetju.org/~edwin/asterisk-sip-reinvite.html
describes a problem I experienced with calls coming from one of our
providers where during the SIP handshake our equipment was reinviting
the SIP session: The RTP stream was never setup. We experienced
this after the upgrade from 1.2 to 1.4 (the latest SVN version),
before that it always has worked.

To simulate this problem, I have setup one SIP phone, three identical
Asterisk instances and a connection towards the end-point: A Cisco
Call Manager. The only varying factor in the experiments was the
option "canreinvite": When using "canreinvite=no", it always worked
fine, but when using "canreinvite=yes", it broke down after two

I have written down the whole setup, the configurations, the scenarios
and the results at http://www.mavetju.org/~edwin/c2-flow.txt.
Attached to each scenario are the SIP packets (captured with ngrep
and processed into a flow visualiser).

I hope that this can help you to find out if this is a problem with
Asterisk. Oh, and help me to get the RTP streams directly between
the two end-stations instead of via the Asterisk box. Once I have
feedback from somebody I can open a bug at Mantis to bring it under
the developers attention.

Edwin Groothuis      |            Personal website: http://www.mavetju.org
edwin at mavetju.org    |              Weblog: http://www.mavetju.org/weblog/

More information about the asterisk-dev mailing list