[Asterisk-Dev] wcusb driver / productID

Michel Belleau mbelleau at gvq.qc.ca
Tue Jul 20 11:41:29 MST 2004

I think I found something about this..


The developper kit that I have seems to have the TJ560 or TJ560A chip.

The new USB adapter that I received looks like the TJ560B chip (written
underside the adapter).


Theses chips should be compatible (according to the documentation);




Maybe it’s just the fact that we must include the « new » product id in the
zaptel drivers along the old one? I tried changing it in the sources and
recompiling the « wcusb » driver but it crashes my machine.. I think it’s
just because I’m really new at kernel modules hacking ;-)


Michel Belleau





De : asterisk-dev-admin at lists.digium.com
[mailto:asterisk-dev-admin at lists.digium.com] De la part de Michel Belleau
Envoyé : 20 juillet 2004 12:36
À : asterisk-dev at lists.digium.com
Objet : [Asterisk-Dev] wcusb driver / productID


Hi everyone.


Is this device compatible with the « Zaptel » drivers?



I ordered one, it’s physically the same thing as what I received with my
startup kit : one small white box with three holes on top of it, a red led,
rj-11 and usb connectors. The adapter works fine in my WindowsXP
workstation. In Linux, « lsusb » tells me that it’s the same vendorID as the
S100U that I got with my developper kit (that works nicely with
Asterisk/Zaptel, btw). I tried plugging it in my Asterisk Linux Box and it
doesn’t seem to get detected; only the productID is different from the other
USB adapter, I thought the driver would be right for it..


Anyone here tried this adapter?


Thanks, Michel Belleau


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.digium.com/pipermail/asterisk-dev/attachments/20040720/668b28f3/attachment.htm

More information about the asterisk-dev mailing list