<p> Attention is currently required from: Mark Murawski. </p>
<p>Patch set 2:<span style="border-radius: 3px; display: inline-block; margin: 0 2px; padding: 4px;background-color: #ffd4d4; color: #000000;">Code-Review -1</span></p><p><a href="https://gerrit.asterisk.org/c/asterisk/+/19264">View Change</a></p><p>9 comments:</p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0;"><p><a href="null">Patchset:</a></p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264?tab=comments">Patch Set #2:</a> </p><p style="white-space: pre-wrap; word-wrap: break-word;">As a general comment, your spacing is all off. Whitespaces should be converted to tabs, and alignment needs to be fixed.</p><p style="white-space: pre-wrap; word-wrap: break-word;">Also, don't submit against master directly, it should be another branch, and this needs a JIRA issue. Also needs a CHANGES entry.</p></li></ul></li><li style="margin: 0; padding: 0;"><p><a href="null">File channels/chan_dahdi.h:</a></p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/35f72ab6_77e82ec5">Patch Set #1, Line 211:</a> <code style="font-family:monospace,monospace"> unsigned int _busydetect:1;</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">I think this variable should be renamed, and the description updated appropriately. Unclear right now.</p></li></ul></li><li style="margin: 0; padding: 0;"><p><a href="null">File channels/chan_dahdi.c:</a></p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/03d29899_0c104261">Patch Set #2, Line 5920:</a> <code style="font-family:monospace,monospace"></code></p><p style="white-space: pre-wrap; word-wrap: break-word;">This isn't actually implemented yet</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/b74dd3f2_56dda567">Patch Set #2, Line 8682:</a> <code style="font-family:monospace,monospace"> return &p->subs[idx].f;;</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">Duplicate semicolon</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/e7c254e6_43aa74fc">Patch Set #2, Line 9788:</a> <code style="font-family:monospace,monospace"> res = pbx_exec(chan, theapp, NULL);</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">Two things:<br>1) use ast_answer_chan or ast_raw_answer or some C API directly, there is no reason to find the Answer app and execute it.<br>2) Why are we answering the channel at all??? Seems like a big no no to me.</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/b024e4cc_f3f37ed4">Patch Set #2, Line 9791:</a> <code style="font-family:monospace,monospace"> ast_log(LOG_WARNING, "PBX exited non-zero\n");</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">Yeah, and we don't need this either, just call the right ast_ API directly.</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/31d2958f_449f334b">Patch Set #2, Line 11976:</a> <code style="font-family:monospace,monospace"></code></p><p style="white-space: pre-wrap; word-wrap: break-word;">remove</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/6764e864_874c7fa8">Patch Set #2, Line 20378:</a> <code style="font-family:monospace,monospace">// ast_log(LOG_NOTICE, "channels: %s\n", channel_arg);</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">Remove these commented out logs</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/c/asterisk/+/19264/comment/4cc837f2_b7a0f944">Patch Set #2, Line 20540:</a> <code style="font-family:monospace,monospace"> ast_log(LOG_WARNING, "Channel DAHDI/%d busyout queue cancelled\n", dahdi_chan->channel);</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">why is this a warning?</p></li></ul></li></ul><p>To view, visit <a href="https://gerrit.asterisk.org/c/asterisk/+/19264">change 19264</a>. To unsubscribe, or for help writing mail filters, visit <a href="https://gerrit.asterisk.org/settings">settings</a>.</p><div itemscope itemtype="http://schema.org/EmailMessage"><div itemscope itemprop="action" itemtype="http://schema.org/ViewAction"><link itemprop="url" href="https://gerrit.asterisk.org/c/asterisk/+/19264"/><meta itemprop="name" content="View Change"/></div></div>
<div style="display:none"> Gerrit-Project: asterisk </div>
<div style="display:none"> Gerrit-Branch: master </div>
<div style="display:none"> Gerrit-Change-Id: Ib75c87c554bb18b8f65be73b4474474e7e1877b7 </div>
<div style="display:none"> Gerrit-Change-Number: 19264 </div>
<div style="display:none"> Gerrit-PatchSet: 2 </div>
<div style="display:none"> Gerrit-Owner: Mark Murawski <markm@intellasoft.net> </div>
<div style="display:none"> Gerrit-Reviewer: Friendly Automation </div>
<div style="display:none"> Gerrit-Reviewer: N A <mail@interlinked.x10host.com> </div>
<div style="display:none"> Gerrit-Attention: Mark Murawski <markm@intellasoft.net> </div>
<div style="display:none"> Gerrit-Comment-Date: Thu, 15 Sep 2022 23:03:55 +0000 </div>
<div style="display:none"> Gerrit-HasComments: Yes </div>
<div style="display:none"> Gerrit-Has-Labels: Yes </div>
<div style="display:none"> Gerrit-MessageType: comment </div>