<p><a href="https://gerrit.asterisk.org/10550">View Change</a></p><p>3 comments:</p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0;"><p><a href="https://gerrit.asterisk.org/#/c/10550/2/res/res_pjsip_notify.c">File res/res_pjsip_notify.c:</a></p><ul style="list-style: none; padding: 0;"><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/#/c/10550/2/res/res_pjsip_notify.c@898">Patch Set #2, Line 898:</a> <code style="font-family:monospace,monospace">     if (endpoints != NULL && ao2_container_count(endpoints) > 0) {</code></p><p><blockquote style="border-left: 1px solid #aaa; margin: 10px 0; padding: 0 10px;">I wanted to avoid ao2_iterator_init/destroy. […]</blockquote></p><p style="white-space: pre-wrap; word-wrap: break-word;">ao2_iterator_init/destroy are very light weight and I think the nominal case when someone requests this completion is that it won't be empty.</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/#/c/10550/2/res/res_pjsip_notify.c@900">Patch Set #2, Line 900:</a> <code style="font-family:monospace,monospace">               struct ao2_iterator i = ao2_iterator_init(endpoints, 0);</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">A blank line after the variable declarations would be nice for readability.</p></li><li style="margin: 0; padding: 0 0 0 16px;"><p style="margin-bottom: 4px;"><a href="https://gerrit.asterisk.org/#/c/10550/2/res/res_pjsip_notify.c@904">Patch Set #2, Line 904:</a> <code style="font-family:monospace,monospace">                        ao2_cleanup(endpoint);</code></p><p style="white-space: pre-wrap; word-wrap: break-word;">Technically this can be ao2_ref(endpoint, -1) since endpoint cannot be NULL here.</p></li></ul></li></ul><p>To view, visit <a href="https://gerrit.asterisk.org/10550">change 10550</a>. To unsubscribe, or for help writing mail filters, visit <a href="https://gerrit.asterisk.org/settings">settings</a>.</p><div itemscope itemtype="http://schema.org/EmailMessage"><div itemscope itemprop="action" itemtype="http://schema.org/ViewAction"><link itemprop="url" href="https://gerrit.asterisk.org/10550"/><meta itemprop="name" content="View Change"/></div></div>

<div style="display:none"> Gerrit-Project: asterisk </div>
<div style="display:none"> Gerrit-Branch: 13 </div>
<div style="display:none"> Gerrit-MessageType: comment </div>
<div style="display:none"> Gerrit-Change-Id: Ic20024912cc77bf4d3e476c4cd853293c52b254b </div>
<div style="display:none"> Gerrit-Change-Number: 10550 </div>
<div style="display:none"> Gerrit-PatchSet: 2 </div>
<div style="display:none"> Gerrit-Owner: Alexei Gradinari <alex2grad@gmail.com> </div>
<div style="display:none"> Gerrit-Reviewer: Alexei Gradinari <alex2grad@gmail.com> </div>
<div style="display:none"> Gerrit-Reviewer: Corey Farrell <git@cfware.com> </div>
<div style="display:none"> Gerrit-Reviewer: Jenkins2 (1000185) </div>
<div style="display:none"> Gerrit-Reviewer: Richard Mudgett <rmudgett@digium.com> </div>
<div style="display:none"> Gerrit-Comment-Date: Fri, 26 Oct 2018 22:17:05 +0000 </div>
<div style="display:none"> Gerrit-HasComments: Yes </div>
<div style="display:none"> Gerrit-HasLabels: No </div>