[Asterisk-code-review] lock: Replace ast mutex logger with ast mutex logger. (asterisk[13])
Richard Mudgett
asteriskteam at digium.com
Fri Oct 19 08:45:34 CDT 2018
Richard Mudgett has posted comments on this change. ( https://gerrit.asterisk.org/10521 )
Change subject: lock: Replace __ast_mutex_logger with ast_mutex_logger.
......................................................................
Patch Set 1:
(1 comment)
https://gerrit.asterisk.org/#/c/10521/1/include/asterisk/lock.h
File include/asterisk/lock.h:
https://gerrit.asterisk.org/#/c/10521/1/include/asterisk/lock.h@244
PS1, Line 244: #define ast_mutex_logger(canlog, ...) do { if (canlog) ast_log(LOG_ERROR, __VA_ARGS__); else fprintf(stderr, __VA_ARGS__); } while (0)
: #define __ast_mutex_logger(...) ast_mutex_logger(canlog, __VA_ARGS__)
> My patch already drops the __ from the macro and all calls.. […]
I'm saying that this is a private "function" that doesn't need the public naming convention. Also that this should be moved to main/locks.c. This can be done to all branches because it won't break API since it is an internal implementation detail.
--
To view, visit https://gerrit.asterisk.org/10521
To unsubscribe, or for help writing mail filters, visit https://gerrit.asterisk.org/settings
Gerrit-Project: asterisk
Gerrit-Branch: 13
Gerrit-MessageType: comment
Gerrit-Change-Id: I83b372cb0654c5c18eadc512f65a57fa6c2e9853
Gerrit-Change-Number: 10521
Gerrit-PatchSet: 1
Gerrit-Owner: Corey Farrell <git at cfware.com>
Gerrit-Reviewer: Corey Farrell <git at cfware.com>
Gerrit-Reviewer: Jenkins2 (1000185)
Gerrit-Reviewer: Richard Mudgett <rmudgett at digium.com>
Gerrit-Comment-Date: Fri, 19 Oct 2018 13:45:34 +0000
Gerrit-HasComments: Yes
Gerrit-HasLabels: No
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.digium.com/pipermail/asterisk-code-review/attachments/20181019/f15650d0/attachment.html>
More information about the asterisk-code-review
mailing list